Rubyと筋肉とギターとわたし

エンジニア二年目の雑魚です。プログラミング・ギター・筋トレのことをメインにブログを書いていきます。

android studioでkotlinのバージョンをあげたらエラー出るので困った

android studioを立ち上げた時にポップアップでkotlinのupdateが出てきたので、なにも気にせずupdateしました。

すると。。。

outdated kotlin runtime

f:id:rdwbocungelt5:20180316191702p:plain

なんか出た。

とりあえずUpdate Runtimeを押してみる。

f:id:rdwbocungelt5:20180316191822p:plain

はあ。。。

自動でkotlinバージョンを変えることはできないので手動でやらないといけないっぽいです。

まずどこを見たか

Gradle Script配下のbuild.gradle(Project:~~)を確認してみます。

f:id:rdwbocungelt5:20180316192026p:plain

kotlinのバージョンは1.1.51と。

実際どうなってんでしょうね。

f:id:rdwbocungelt5:20180316192403p:plain

Tools -> kotlin -> Configure Kotlin Plugin Updatesで見れました。

その後にChecks for updates nowをクリックしてちょっとすると出てきます。

...バージョン違いますね。

てなわけで修正

f:id:rdwbocungelt5:20180316192655p:plain

ext.kotlin_versionを今のバージョンに変えてあげます。

1.1.51から1.2.30へ修正。

すると上になんか出てきます。Sync Nowをクリック。

問題なければ成功します。以下がそれ。Grandle Consoleに出てきます。

f:id:rdwbocungelt5:20180316193131p:plain

おわり

とりあえずいけましたー

すすめるごとにエラー出るので頑張る